yoo - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 10-06-12 Thread Starter
Status: -
Join Date: Jun 2012
Location: United Kingdom
County: Greater London
Posts: 3

Member car:

alfa romeo


i have a alfa romeo 147 twin spark 1.6 2003 plate.........when i drive for a short period of time on my dash board a message appears saying motor control system failure...i havent tried nothing yet...what should i do + how much is it going to cost and what garage can i go to in london if so as close to hackney as possible
aaron1231 is offline  
Sponsored Links
Status: Still Happily Married..........
AO Platinum Member
dpat's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Cheshire
Posts: 32,403
Images: 20
welcome to AO

Post your question in the 147 technical lounge and you will get a better response. This is a lounge to say 'hello' only.

dpat is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome