Just got me a 147 :) but heylppppp... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
Jimbo1973
Status: - Update
Guest
 
Posts: n/a
Just got me a 147 :) but heylppppp...

Hiya People,

Just thought I would say hello to you all as i'm a newbie Alfa owner. I picked up a bargain Alfa 147, 2.0 TS Lusso last night, it's a 2001 with leather, bose system, one owner and also Sat Nav which I need to ask a question about if possible please.

On switching on the ignition the Sat Nav screen comes on with the Alfa logo, but then I don't seem to be able to do anything with it. Have tried following the instruction guide which says I should be presented with a menu to scroll through, but I can't even get that far.

The car was bought from a local small trader and I assumed that the Sat Nav would be functioning as it was advertised with the car and on test drive seeing the screen come on e.t.c lead me to believe all was OK. On asking the trader whether the Sat Nav needed a card to put in the slot he said that he had only just picked up the car and not used the Sat Nav himself, but that it would maybe need a code as the battery may have been disconnected at some point. However, it doesn't ask for a code or give me an option to input a code and on disconnecting the battery it made no difference.

Any help or guidance on this would be very much appreciated.

Thanks.

Jim in Cardiff.
 
Sponsored Links
Advertisement
 
Status: frenzied burrowing
AO Platinum Member
 
Fraser's Avatar
 
Join Date: Mar 2003
Location: United Kingdom
County: South Lanarkshire
Posts: 19,680
Images: 8
Re: Just got me a 147 :) but heylppppp...

Hi Jimbo and welcome to the forum. I don't know the answer to your query but I would suggest you post this in the 147 tech lounge. You're more likely to get an answer there (more people look at that lounge I think).
Fraser is offline  
Jimbo1973
Status: - Update
Guest
 
Posts: n/a
Re: Just got me a 147 :) but heylppppp...

Thanks Fraser, will do and happy motoring

Cheers,

Jim.
 
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Tags
147 , heylppppp

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome