I want to buy a Mito... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 23-04-12 Thread Starter
Status: -
Join Date: Apr 2012
Location: United Kingdom
County: Essex
Posts: 1

Member car:


Wave I want to buy a Mito...

Hi all,

Im new to this site, was wondering if any of you could give me some info on the Mito range. I am keen to buy a 1.4L 95bhp Veloce. What should I look out for when buying?? Are there any common faults with the car?

Many thanks
DGO7MITO is offline  
Sponsored Links
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to AO.....plenty of help and advic ein the Mito tech lounge.....
A short buyers guide here.....Alfa Romeo Mito Buyers Guide
Stu GTV is offline  
Status: Pain in the veins, but passion in the blood
AO Silver Member
giordano92's Avatar
Join Date: Oct 2009
Location: Australia
County: New South Wales
Posts: 4,378
Images: 10
Welcome to AO

Saluti, Giordano.
giordano92 is offline  
Status: -
Join Date: May 2012
Location: United Kingdom
County: Staffordshire
Posts: 2

Member car:

Alfa Mito

Mito - my worst car ever!

I would not recommend a Mito to anyone!

I bought my brand new Mito in August 2011 from Platts in Stoke-on-Trent. I've had lots of problems, both with the car and with poor customer service - both the dealership and Alfa customer services. Here's the problems I've had:
  • Paint blemishes
  • Gearbox problems after 8,000 miles - rebuilt/repaired but not properly
  • New gearbox as they hadn't a clue what was wrong with it - but took 6 weeks to get the part and get it installed
  • Noise on starting up when cold - they thought it was the alternator, then thought it was water pump. Ordered parts - took 2 weeks to arrive. They had the car in to repair and then decided it wasn't either of these but the oil pump. That took nearly 2 weeks to arrive. Repaired the car - but not properly - oil pressure warning light kept coming on. Been back in today to have that fixed.

As a driving instructor I've had several cars .... this is the worst car for reliability I have ever owned and it's cost me a fortune in cancelled driving lessons. The car has been in the garage for approx 20 days in 10 months!

Last edited by Kevin P; 15-05-12 at 21:25.
Kevin P is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

buy , mito

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome