Electrical fault nightmare 147 Lusso - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 22-02-12 Thread Starter
Status: -
AO Member
Join Date: Feb 2007
Location: Dundee Scotland
Posts: 15
Help Electrical fault nightmare 147 Lusso

Hi, Just thought id share with you a nightmare I am having with an alfa 147 lusso. 2005 reg and only done 20000 miles. was my fathers car and he unfortunately passed away in November - I inherited the car and...it hasnt worked since! thought it was flat battery - came up imobilisor failure - so got it towed to garage - they took the two ignition keys and checked they were correctly programmed - which they were. garage replaced battery only to find new one one drained of charge next day. - they have worked on car seemlingly for 5 hours cannot find fault - and so are suggesting a new CPU - cost of repair up till now is 1300.........HELP! they say they cannot guarentee a new cpu will fix problem....come on you guys - rise to this challenge! help me!!!!
mel1gib is offline  
Sponsored Links
(Post Link) post #2 of 4 Old 22-02-12 Thread Starter
Status: -
AO Member
Join Date: Feb 2007
Location: Dundee Scotland
Posts: 15
Oops - just read heading - introduce yourself....no technical questions here.....doh...ok - names Heather - from Dundee - alfa enthusiast - but - champaigne lifestyle - lambrini budget.....Help!
mel1gib is offline  
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello Heather and welcome to AO......

If you ask for help and advice in here.......Alfa 147, 156 & GT - Alfa Romeo Forum you should get a better response..........

The problem with a garage you don't know and trust they can tell you anything and while they have your car you either pay or they won't let you have it back........
You could ask in here......Scotland - Alfa Romeo Forum if anyone knows a good and honest indie garage in your area......
1300 for 5 hours tinkering and a new battery is daylight robbery........
Stu GTV is offline  
Status: Pistonless.
AO Member
Join Date: Sep 2011
Location: Portugal
County: Faro
Posts: 573

Member car:

Mazda RX-8

Hello and welcome to AO.
Hope you can solve those problems quickly.
Good luck and enjoy the forum.
RuiX8 is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

147 , electrical , fault , lusso , nightmare

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome