New Member!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 12-01-05 Thread Starter
Status: in need of a 145 1.7 boxer!!
AO Member
 
Join Date: Jan 2005
Location: Ireland
County: Dublin
Posts: 50

Member car:

156 1.8

Help New Member!!!

Hi All.

I'm Raj... new member to AO.
New to Alfas as well. Just bought a 1995 146 1.6 boxer.
Looking to learn more bout these beauties.
She needs a few tweeks here n there.
Sorted most out but cant seem to figure out one thing.

If anyone has seen this before pls help!!

The injecter light comes on when the engine is warm, usually around 50 degrees. Took it to an Alfa garage but apparently the equipment they have has been updated and my ECU is too old for them to do diagnostics. Anyone have any ideas on what could be causing the injecter light to come on?

Regards,
Raj
Mahendaraj is offline  
Sponsored Links
Advertisement
 
Status: ready4vacations
AO Platinum Member
 
THROTTLEMAN's Avatar
 
Join Date: Jul 2002
Location: Portugal
County: Porto
Posts: 31,304

Member car:

Alfa 159 QV

Re: New Member!!!

Hi Raj, welcome to Alfaowner.

I'm guessing that you probably have a problem with the lambda sonda...

If you would like to show some shots of your Alfa, you're welcome to post them.
THROTTLEMAN is offline  
Status: 660Nm of torqueystuff!
AO Platinum Member
 
Hunter's Avatar
 
Join Date: Dec 2004
Location: British Indian Ocean Terr
County: -
Posts: 15,150
Images: 37
Re: New Member!!!

Welcome Raj!
Hunter is offline  
Status: -
AO Rosso Alfa Member
 
kurzon's Avatar
 
Join Date: Jul 2004
Location: London, UK
Posts: 45,472
Images: 1

Member car:

156 2.0 JTS

Re: New Member!!!

Try searching the tech forums for the problem you have described or take it to an alfa specialist who should have the appropriate equipement.

Welcome to AO forum Raj
kurzon is offline  
Status: up to my eyeballs in work :-(
AO Gold Member
 
Green Cloverleaf's Avatar
 
Join Date: Jun 2004
Location: United Kingdom
County: Hampshire
Posts: 7,160
Images: 13
Re: New Member!!!

Welcome to the forum, Raj


As Kurz said, an independant Alfa garage should have the appropriate diag equipment for your car. If you let us know where you are based, I'm sure some of the more local members here will know the name of a good place.


Also, as Throttleman said, you are most welcome to post lots of piccies of you car, for our viewing pleasure
Green Cloverleaf is offline  
Status: 0.9 turbo power....
AO Silver Member
 
p17sut's Avatar
 
Join Date: Nov 2004
Location: United Kingdom
County: Fife
Posts: 3,221
Images: 33

Member car:

500 twinair

Re: New Member!!!

Welcome to AO.

Study the 145/146 forum, i'm sure there will be something in there to help you!
p17sut is offline  
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Tags
member

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome