Alfa - love it..., err, hmmm? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 24-09-11 Thread Starter
Status: -
Join Date: Aug 2011
Location: South Africa
County: Gauteng
Posts: 7
Images: 2
Alfa - love it..., err, hmmm?

Hi everyone,
I am 23 years old, live in South Africa, and I've had my 147 for just over 2 years - It's my 3rd car.

1st car was a 1966 Mk1 Cortina 2 door with a 1600 xflow kent motor, 36DCD weber, branch, Cyclone mags etc. Bought as a "project car" for me and my dad to build up.
Didn't really get to drive it much though because I was still under age and my Dad and I didn't get around to finishing the build - shame really. We didn't get our money back selling that one

2nd car was a 1998 Toyota Tazz 1.3. Great car. We added nice mags and some sound and it just went on forever, and forever.

Then I wanted to upgrade and was looking at Subaru, Ford Focus or similar - We saw this beautiful looking Alfa 147, I drove it and it wasn't just love at first sight, it was also love at first drive. Despite what others said, we bought it anyway - and that's where the love/hate relationship started.

Today - oh well, another puddle of "selespeed" fluid under the car again!
Just hope I get to work. Still need to pay off the last R33,500 repair bill and I've only had the car back for almost 2 weeks after being without transport for over 2 months.

Are all selespeeds so useless? or have I bought a dog?
(Previous owner of the car was a sales manager at the local Alfa agent - I wonder why he traded it in at another dealership? and I wonder what car he bought? hmmm)

Anyway, I still love my Alfa, at least, more than my father loves his ex-wife anyway, and I intend to work through all the issues, so please watch out for my many posts to come in the technical section.

Thanks for a great website.

Last edited by 14S7EVEN; 24-09-11 at 19:41. Reason: duffed the 1st try
14S7EVEN is offline  
Sponsored Links
Status: Meh.
AO Platinum Member
NineOneSix's Avatar
Join Date: Dec 2006
Location: United Kingdom
County: Hertfordshire
Posts: 30,067
Images: 9

Member car:

GTV V6 3.0

Welcome mate

Sele's are known to be a bit temperamental. hopefully the leak isn't too bad
NineOneSix is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,036
Images: 2
Welcome to AO waving
classicgal93 is offline  
Status: Pain in the veins, but passion in the blood
AO Silver Member
giordano92's Avatar
Join Date: Oct 2009
Location: Australia
County: New South Wales
Posts: 4,378
Images: 10
Welcome to AO

Salute, Giordano.
giordano92 is offline  
Status: GTA it is.....
AO Silver Member
Join Date: Jan 2008
Location: South Africa
County: KwaZulu-Natal
Posts: 2,756

Member car:

147 GTA

Welcome dude

Come say hello in here; South Africa - Alfa Romeo Forum

There are a few chaps in the JHB area that have had small niggles with the Selespeed, they will be happy to help Plus they know a few small tricks as well
masonGTA is offline  
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to AO.....
Stu GTV is offline  
Status: Je suis l'dauphin d'la place Dauphine
AO Platinum Member
Al Faromeo's Avatar
Join Date: Apr 2005
Location: Netherlands
County: Limburg
Posts: 25,337
Images: 8

Welcome to AO!

And if you have a couple of CPU cycles to spare on your laptop or home PC:
Al Faromeo is offline  
(Post Link) post #8 of 8 Old 26-09-11 Thread Starter
Status: -
Join Date: Aug 2011
Location: South Africa
County: Gauteng
Posts: 7
Images: 2
Thanks for the warm welcome.

Sele leak has slowed down now. Not because it's empty, but checking it the proper way as we've just learn't through reading some of the tech posts here. It is still just a teenie bit overfull.
Don't know why it took so long before fluid hit the floor though.
Perhaps the new under engine cover pan that was fitted two weeks doesn't leak as badly as the last one.

Talk to you again.

Once again, thanks for the welcome.

14S7EVEN is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

alfa , err , hmmm , love , selespeedum

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome