Hi - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 9 Old 25-08-11 Thread Starter
Status: sooo not missing my MX-3 :-D
AO Member
DeeJayB's Avatar
Join Date: Aug 2011
Location: United Kingdom
County: Derbyshire
Posts: 34

Hi all
New member here, just got my first Alfa Romeo... it's a 147 1.9 JTD Lusso
I've always been a Mazda driver in the past but thought I'd try something different - I've just got rid of an MX-3 V6 coupe.
I have to say I'm loving my new 147 so far, despite the numerous but occaisonal warning lights lol. I don't think it will be my only Alfa I own...

I've already learnt so much from this site, so thanks! Pretty sure I'll have more questions lol

DeeJayB is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,050
Images: 2
Welcome to AO Dave waving and congrats on your 147
classicgal93 is offline  
Status: Still Happily Married..........
AO Platinum Member
dpat's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Cheshire
Posts: 32,403
Images: 20
welcome to AO, enjoy your 147 Ti
dpat is offline  
Status: diem25.org
Club Member
Membro Premio
Elvis Presley's Avatar
Club Member Number: 59
Join Date: Aug 2006
Location: In a rockin good place
County: Memphis
Posts: 72,956
Images: 5

Member car:

A galleon

howdy and welcome
Elvis Presley is offline  
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to AO....
Stu GTV is offline  
Status: Pain in the veins, but passion in the blood
AO Silver Member
giordano92's Avatar
Join Date: Oct 2009
Location: Australia
County: New South Wales
Posts: 4,378
Images: 10
Welcome to AO

Salute, Giordano.
giordano92 is offline  
(Post Link) post #7 of 9 Old 27-08-11 Thread Starter
Status: sooo not missing my MX-3 :-D
AO Member
DeeJayB's Avatar
Join Date: Aug 2011
Location: United Kingdom
County: Derbyshire
Posts: 34
Hey, thanks for the hellos
I've had my 147 for 5 days now, and yes I am addicted!!
Read loads on here... patched my leaky turbo hose (can't afford a new one right now so used an exhaust bandage which seems to be up to the job so far..), did a full charge of the battery and the "ecu reset" restart procedure and took it out for drive. Drove 40 miles with a big smile on my face lol. And so far no repeats of MCSF or VDC failure messages.
Also, neighbours I've never said more than "hello" to suddenly want to come over and talk about my car!! So funny.
Anyways, hope at some point I can contribute back to the wealth of knowledge and help on here.

(still grinning ear to ear)
DeeJayB is offline  
Status: Je suis l'dauphin d'la place Dauphine
AO Platinum Member
Al Faromeo's Avatar
Join Date: Apr 2005
Location: Netherlands
County: Limburg
Posts: 25,338
Images: 8
Well done Dave
Welcome to AO!

And if you have a couple of CPU cycles to spare on your laptop or home PC: http://www.alfaowner.com/Forum/way-o...home-team.html
Al Faromeo is offline  
Status: Making Ron Jeremy look small !
AO Platinum Member
howell811's Avatar
Join Date: Mar 2007
Location: Virgin Islands (British)
County: -
Posts: 26,529

Member car:


Welcome along
howell811 is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome