Mike D - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 08-08-11 Thread Starter
Status: -
Join Date: Aug 2011
Location: United Kingdom
County: Wiltshire
Posts: 2
Mike D

Hi, first time visitor so bear with me!

Been an ***** owner since '01 with a 156 Wagon, after 217,000 miles decided a new one was in order!
Bought a 159 2.4 jTD Wagon on an 08 in Feb 09, ex demo, all going well till 2 months ago, been in garage over past months cannot get to bottom of power loss problem, replaced EGR valve twice and just about everything else, luckily under warranty!
Any answers as to what problem might be? Completely looses power.
DuhigM is offline  
Sponsored Links
Status: diem25.org
Club Member
Membro Premio
Elvis Presley's Avatar
Club Member Number: 59
Join Date: Aug 2006
Location: In a rockin good place
County: Memphis
Posts: 72,934
Images: 5

Member car:

A galleon

Hope you get it sorted, Mike. Welcome to AO.

some pointers here???

Elvis Presley is offline  
Status: Je suis l'dauphin d'la place Dauphine
AO Platinum Member
Al Faromeo's Avatar
Join Date: Apr 2005
Location: Netherlands
County: Limburg
Posts: 25,338
Images: 8
All the best for getting your baby fixed
Welcome to AO!

And if you have a couple of CPU cycles to spare on your laptop or home PC: http://www.alfaowner.com/Forum/way-o...home-team.html
Al Faromeo is offline  
Status: Pain in the veins, but passion in the blood
AO Silver Member
giordano92's Avatar
Join Date: Oct 2009
Location: Australia
County: New South Wales
Posts: 4,378
Images: 10
Welcome to AO

Salute, Giordano.
giordano92 is offline  
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to AO......
Stu GTV is offline  
Status: Still Happily Married..........
AO Platinum Member
dpat's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Cheshire
Posts: 32,403
Images: 20
welcome to AO, take SIFs advice and then search the tech lounge
dpat is offline  
Status: making daily raids across the border
AO Gold Member
alfaholic's Avatar
Join Date: Aug 2001
Location: United Kingdom
County: Surrey
Posts: 6,451

Member car:

6C 2500

Welcome, hope you get your bella fixed
alfaholic is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome