temp too high - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 29-06-11 Thread Starter
Status: -
Join Date: Jun 2011
Location: United Kingdom
County: Devon
Posts: 1

Member car:

gtv 2 litre

Hmmm temp too high

never done this so my engine is very hot rad is cold no pressure in hose from eigine do you think it sounds like water pumps gone its gtv 2 litre .only got it 2 days ago looks brill but not alot to spend im not really thick but never needed to do my own repairs befor thanks not good on pc either
robert toms is offline  
Sponsored Links
Status: Let me see your war face!
AO Gold Member
SpiderMonkey's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: South Yorkshire
Posts: 6,083
Images: 19
Welcome into AO :wave: Robert try a post in the GTV lounge
SpiderMonkey is offline  
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to AO.....hope the tech lounge provided your answer......
Stu GTV is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

high , temp

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome