GTV 3.0L 24V will not start - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 26-06-11 Thread Starter
Status: -
Join Date: Mar 2011
Location: United Kingdom
County: Gloucestershire
Posts: 4

Member car:

GTV 3.0L 24V

GTV 3.0L 24V will not start

Code light wouldn't go out, engine would not fire.

The answer was the ECU power up relay (8.50 from Alfa). There are two located on a relay bank under the plastic cover of the F/O/S wheel. One powers the other which in turn powers up the ECU. An easy check if you have the same problem.

A month later, same problem - this time it was a dodgy connection on the low voltage cable going into the yellow immobiliser module strapped to the steering column under the dash. A good clean up of the 2 plugs and module connections solved this problem.
ISO John is offline  
Sponsored Links
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to AO....thanks for the info.......
Hope yours is now running perfectly.......
Stu GTV is offline  
Status: Let me see your war face!
AO Gold Member
SpiderMonkey's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: South Yorkshire
Posts: 6,083
Images: 19
Welcome into AO :wave:
SpiderMonkey is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

24v , 30l , gtv , start

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome