(2001) 156 2.0 TS Exhaust and Catalytic problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 06-06-11 Thread Starter
Status: -
Join Date: Apr 2011
Location: United Kingdom
County: Greater London
Posts: 2
(2001) 156 2.0 TS Exhaust and Catalytic problems


2 months ago I bought a 156 2.0 TS (2001). First time it seemed like a reliable car, but things started to change. Had a "little" problem with the suspension and needed new thick oil, which was around 350. Now the steering makes some funny noise when the engine is cold, sounds like there is SAND in it, but this is nothing serious yet. Last night my exhaust "blown up" right when i drove over a speed bump. I dont know if it has anything to do with it as the music was on...but i could hear something wasnt right with the exhaust. I took it to kwik fit(thinking its nothing serious) and they told me it would need new rear and middle exhaust pipe or box and a new catalytic. First they said 650 and after they can "knock off" 110, so now its 540.
Since this exhaust problem, when i rev it and it goes down from above 2000rpm, it will stop and stay on 1500rpm for about 1-2 sec by itself!!

Do you guys think it is the right price and if so how come they can give me a cheaper price 5mins later?!

Also what else should i expect?? or tell them to check out..

Sugafree is offline  
Sponsored Links
Status: Je suis l'dauphin d'la place Dauphine
AO Platinum Member
Al Faromeo's Avatar
Join Date: Apr 2005
Location: Netherlands
County: Limburg
Posts: 25,338
Images: 8
Hi mate, get yourself over to the tech forums (there are specific model lounges with loads of technical know-how) - hope you get your issues sorted

Welcome to AO!

And if you have a couple of CPU cycles to spare on your laptop or home PC: http://www.alfaowner.com/Forum/way-o...home-team.html
Al Faromeo is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:

Hope you get it sorted
nigelread is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

156 , 2001 , catalytic , exhaust , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome