The Alfa Bug - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 30-05-11 Thread Starter
Status: -
Join Date: May 2011
Location: United Kingdom
County: South Lanarkshire
Posts: 3
The Alfa Bug

Picked up a 57 plate alfa 159 2.4 Jtdm Lusso in red about three weeks ago and must say that already i have fallen in love with this car!

I have always enjoyed my cars and have had sporty little hatchbacks in the past ( saxo vtr, saxo vts, cliosport 172) but lately have had company cars, German ones, which although are nice they lack a certain passion and feel.

The alfa however takes me back to the days when i enjoyed driving and i have a rekindled love for twisty roads and sweeping corners.

Sadly though i have already experienced the much talked about frustration of the alfa owner when the car started to run a bit rough and the engine management light reared it's ugly face only to disappear a day later. From reading other threads i imagine this is caused either by the egr valve or dpf system but thankfully the car came with a warranty so no biggie.

Sounds mental, especially seeing as i have only had it three weeks and already experienced a problem but i would highly recommend this car to anyone who appreciates a drivers car.

Next step has to be a v6 ti!!! Hopefully next year!
hendy1983 is offline  
Sponsored Links
Status: Pondering powerflex..
AO Silver Member
Redmatt75's Avatar
Join Date: Mar 2011
Location: United Kingdom
County: Greater Manchester
Posts: 2,428
Images: 4
Great choice of car! welcome to AO
Redmatt75 is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:

Great choice of Alfa
nigelread is offline  
Status: Je suis l'dauphin d'la place Dauphine
AO Platinum Member
Al Faromeo's Avatar
Join Date: Apr 2005
Location: Netherlands
County: Limburg
Posts: 25,338
Images: 8
Now get it chip-tuned
Welcome to AO!

And if you have a couple of CPU cycles to spare on your laptop or home PC:
Al Faromeo is offline  
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to AO.......
Stu GTV is offline  
Status: Satisfied
AO Member
bokway's Avatar
Join Date: Mar 2011
Location: Australia
County: -
Posts: 16

Member car:

166 V6 Sporto

Hey Hendy1983: welcome. The only thing better than a newish Alfa is a newish Alfa with a warranty! Happy motoring . . .

Red Desert
bokway is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

alfa , bug

« hi everyone | Heylo »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome