RADIATOR HOSE FAILURE on 159 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 17-05-11 Thread Starter
Status: -
Join Date: May 2011
Location: United Kingdom
County: Oxfordshire
Posts: 1

Member car:

159 1.9 jtdm


Failure of front radiator hose on 159 1.9 jtdm at 29000 miles caused by constant vibration/rubbing against sharp edge of fan housing. Garage who undertook repair with replacement factory part commented "this is a design defect and will fail again so we have double sheathed the new hose".

Alfa Romeo deny any design fault.
ROBERTI is offline  
Sponsored Links
Status: Deleted
AO Gold Member
jillyflower's Avatar
Join Date: Jul 2006
Location: United Kingdom
County: Peterborough, Cambs
Posts: 10,976
Images: 8
Poor you This takes me back to the MiTo's catching fire. Hope you get it sorted And I hope you'll stay around on AO, there's lots of helpful stuff and folk too
jillyflower is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:

Not heard of this problem before

Thanks for letting us know
nigelread is offline  
Status: Je suis l'dauphin d'la place Dauphine
AO Platinum Member
Al Faromeo's Avatar
Join Date: Apr 2005
Location: Netherlands
County: Limburg
Posts: 25,338
Images: 8
It's a way to say "Hi" I guess... Never heard of it on the forum though...
Anyway: Welcome to AO!

And if you have a couple of CPU cycles to spare on your laptop or home PC: http://www.alfaowner.com/Forum/way-o...home-team.html
Al Faromeo is offline  
Status: Pain in the veins, but passion in the blood
AO Silver Member
giordano92's Avatar
Join Date: Oct 2009
Location: Australia
County: New South Wales
Posts: 4,378
Images: 10
Welcome to AO

eeekkkk bit of a problem, thanks for pointing that out

Salute, Giordano.
giordano92 is offline  
Status: Let me see your war face!
AO Gold Member
SpiderMonkey's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: South Yorkshire
Posts: 6,083
Images: 19
Welcome into AO :wave: check out the tech lounge Alfa 159, Brera & 946 Spider - Alfa Romeo Forum
SpiderMonkey is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

159 , failure , hose , radiator

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome