Gtv owner - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 18-04-11 Thread Starter
Status: -
Join Date: Apr 2011
Location: United Kingdom
County: Essex
Posts: 4
Thumbs Up Gtv owner

Hi to all,
I am a new GTV owner, have some tech issues if you could help out I would be really grateful.

I am a Corporate Jet salesman, single and live in Essex !!

I have a problem with the car 'missing' or some call it 'pinking' , it does not
miss when idling in neutral or does it seem to miss when going above 50 mph,
it does it between about 10mph - 40mph. I took it to the local Alfa dealer
and they said they plugged it in and the only error that came up was
a Phase Sensor error, but it seems to replace this means replacing a lot
more at the same time. Does anyone know exactly what it is involved in
this as the dealer didn't really say. The water pump also seems a little
noisy and there is a terrible smell of oil in the cabin, there are no leaks
but the engine does have an oil mist over it and the dealer suggested
an engine clean but did say that the manifold was blowing and needed
a new gasket, that could be accounting for the oil fumes, does this sound right?

Any help or advice would be much appreciated
blondbear is offline  
Sponsored Links
Status: - Update
Posts: n/a
Welcome to AO.

You'll have better luck with your question if you post it in the GTV lounge
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to AO.....hope the tech lounge can help you sort the problem......
Stu GTV is offline  
Status: Pain in the veins, but passion in the blood
AO Silver Member
giordano92's Avatar
Join Date: Oct 2009
Location: Australia
County: New South Wales
Posts: 4,378
Images: 10
Welcome to AO

Salute, Giordano.
giordano92 is offline  
Status: Je suis l'dauphin d'la place Dauphine
AO Platinum Member
Al Faromeo's Avatar
Join Date: Apr 2005
Location: Netherlands
County: Limburg
Posts: 25,338
Images: 8
Welcome aboard.
Hope you get your issues sorted.

Al Faromeo is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:
nigelread is offline  
Status: -
AO Gold Member
mokicat's Avatar
Join Date: Jul 2010
Location: United Kingdom
County: East Ayrshire
Posts: 7,904

Member car:


Might be your cam sensor - tech will help you more. Welcome to the world of GTV's
mokicat is offline  
Status: Looking for a BMW 330D...
AO Gold Member
Starkers's Avatar
Join Date: Nov 2008
Location: Brighton.
County: Good old Sussex by the sea
Posts: 11,228
Images: 2

Member car:

The train :(

Firstly welcome to Alfa Owner. Good luck with the car - you seem to have a few problems early on...., I hope you haven't bought a lemon. Did the car come with full service history?

As others have said, go to the technical lounge for the Alfa Gtv and 916 Spider, start a new thread and enter your technical enquiry.
Starkers is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

gtv , owner

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome