Heh yawl from St.Albans - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 25-03-11 Thread Starter
Status: -
AO Member
Gabs's Avatar
Join Date: Mar 2011
Location: United Kingdom
County: Hertfordshire
Posts: 12
Heh yawl from St.Albans

Hellooo, just purchased a silver 156 2.0 TS Selespeed Veloce

Thought I'd lose my posting virginity here and intro myself, Im Gabriel, friends call me Gabs...like a bit of DIY and working out things myself, mostly through trial and error but get there in the end!

Been carless for a few years as worked abroad but now loving the Alfa experience, well almost...no techi stuff here right so will browse the threads for solutions to the clunking suspension over bumps and slugish power (MAF?)...oooopppss, did I just break the rules haha!

Anyway, looking forward to meeting some of you at some stage, and hopefully get my Alfa up to standard, hopefully at not too much cost!


Gabs is offline  
Sponsored Links
Status: http://youtu.be/9fF_ WX_AOYg
AO Silver Member
RossoGT's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: Hertfordshire
Posts: 1,124
Images: 5

Member car:

Ex GT 3.2 V6

Welcome to the club Gabs make sure you get some pictures up of your alfa
RossoGT is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:
nigelread is offline  
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to AO......you seem to have the rules worked out already so you should not have any problems on here...............
Stu GTV is offline  
(Post Link) post #5 of 6 Old 27-03-11 Thread Starter
Status: -
AO Member
Gabs's Avatar
Join Date: Mar 2011
Location: United Kingdom
County: Hertfordshire
Posts: 12

Had the car less than a week and already issues galore! Mostly just wear and tear as its a 2000 reg 156 2.0 TS, but couple of worrying things.

Been thru the threads and done alot of research and nailed down the issues, but trying to get seller (Luton trader) to sort it out as was provided with brand new MOT but took to Autolusso for a check up, and was told car should not have passed as suspension play is too worn to be totally safe!

They told me about my rights, even for used older cars so fingers crossed it gets sorted cos dont wana give the car back!

Need upper and lower wishbones replaced.

On the plus side, I've worked out the power issue. Pulls away really slow, narrowd down to various things but garages didnt pick them up! Was told its a Lamda sensor, but I did the MAF disconnect and wow, quick! Gona try cleaning it up today to see if will fix, otherwise new MAF!

Im pretty good at figuring stuff out, but not happy about the wishbone condition of the car when bought, very clunky over bumps and Autolusso told me the lower nearside could pop off quite easily! Took to the MOT garage as suspect they're 'friends' withthe trader who sold me the car.

Naturally they said not that bad but dos need replacing and even said they'd sort something out with the seller to help me out...very suspiscious right, why would they do that? Anyway, if they fix it up then cool, but if I have to pay then I'll go to VOSA after getting another MOT garage to check it out, backed up with Autolusso's recommendations...Ned and James were exceptionally helpful and thorough, although MAF issue was missed (heard it doesntshow on Dagnostic though).

Ok, off to get some Carb cleaner then clean the MAF, hopefully get that sorted and fingers crossed they fix my wishbones without me paying.

What do you guys think about my consumer rights? If indeed the wishbones are in such a state the car isnt safe...can I request a complete refund? Car wasnt advertised as parts or anything like that...£900 for W re with 117000 miles.
Gabs is offline  
Status: Je suis l'dauphin d'la place Dauphine
AO Platinum Member
Al Faromeo's Avatar
Join Date: Apr 2005
Location: Netherlands
County: Limburg
Posts: 25,338
Images: 8
Welcome aboard

Sorry can't help you re. your rights as not familiar with the funny laws of your strange country - but I do hope you get everything sorted!
Al Faromeo is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

heh , stalbans , yawl

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome