Alfa 156 fault codes - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools
  (Post Link) post #1 of 5 Old 18-02-11 Thread Starter
Newbie
 
Join Date: Sep 2010
Location: United Kingdom
Posts: 19
Alfa 156 fault codes

i have 11 error codes on my 156 sportwagon. p0300 random multi misfire. p0303 cylinder 3 misfire. p0302 cyl 2 misfire, p1173, p1177,p1178, p0137 o2 sensor circuit bank 1 sensor 2, p0150 o2 sensor circuit bank 2, p0115 engine coolant temp sensor 1 circuit , p0301 cylinder 1 misfire and p0304 cylinder 4 misfire.
i have no knowledge of cars in the slightest. I have had the back box done but reallly that hasnt helped. max speed is about 45, thye petrol light is on constantly. i am looking for help advise what ever you can pass at me. I have been told that by diagnostic they think that if the o2 is replaced should be ok, but also said that to check for holes or splits in the pipes around???? can anyone help???? ( i must also say that i am no mechanic, so do not understand these terms.) youmay answer me as a 3 year old!! (there will be no offence taken) Thanks to you all!!!!!! if u can help greatly appreciated. Simon in Wales. (the car is 2001 y reg. 156 ts. 1800. ) when i took it to the garage he said that he cant nsee that it is the centre exhaust or the cat????? but like i said i have no clue. thanks again.
SJR 777 is offline  
  3 Latest Threads by SJR 777
Thread Forum Last Poster Replies Views Last Post
156 sportwagon help Alfa 147, 156 & GT SJR 777 4 432 01-12-11 22:30
that engine light and air bag light Alfa 147, 156 & GT CroBaron 34 6513 25-02-11 21:15
please help Alfa 147, 156 & GT SJR 777 8 886 20-02-11 08:32
Sponsored Links
Advertisement
 
  (Post Link) post #2 of 5 Old 18-02-11
AO Member
 
mini jts's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
Posts: 225

Member car:

156 jts

Quote:
Originally Posted by SJR 777 View Post
i have 11 error codes on my 156 sportwagon. p0300 random multi misfire. p0303 cylinder 3 misfire. p0302 cyl 2 misfire, p1173, p1177,p1178, p0137 o2 sensor circuit bank 1 sensor 2, p0150 o2 sensor circuit bank 2, p0115 engine coolant temp sensor 1 circuit , p0301 cylinder 1 misfire and p0304 cylinder 4 misfire.
i have no knowledge of cars in the slightest. I have had the back box done but reallly that hasnt helped. max speed is about 45, thye petrol light is on constantly. i am looking for help advise what ever you can pass at me. I have been told that by diagnostic they think that if the o2 is replaced should be ok, but also said that to check for holes or splits in the pipes around???? can anyone help???? ( i must also say that i am no mechanic, so do not understand these terms.) youmay answer me as a 3 year old!! (there will be no offence taken) Thanks to you all!!!!!! if u can help greatly appreciated. Simon in Wales. (the car is 2001 y reg. 156 ts. 1800. ) when i took it to the garage he said that he cant nsee that it is the centre exhaust or the cat????? but like i said i have no clue. thanks again.
Today i had po304 misfire and other codes it was my coil pack on cyl 4.luckily had a spare coil pack problem solved.Cant say though for sure if p1173 p1177,p1178 are connected to your problem think they are.Have you topped up oil recently if any was spilt can affect coil packs.Do check connection to coil packs hope you get it sorted....................

Doing a search has come with many possible causes,so if you put in fault codes and do some reading it may help you understand the codes better again good luck.......

Last edited by mini jts; 18-02-11 at 15:56.
mini jts is offline  
  (Post Link) post #3 of 5 Old 18-02-11
AO Platinum Member
 
nigelread's Avatar
 
Join Date: Sep 2006
Location: United Kingdom
Posts: 22,300
Images: 5
Hello and Welcome :wave:

Post your question in the tech lounge you will get a better response
nigelread is offline  
  (Post Link) post #4 of 5 Old 18-02-11
AO Member
 
alfamito155tb's Avatar
 
Join Date: Feb 2011
Location: Portugal
Posts: 941
Images: 2
Welcome to AO mate good luck with the codes
alfamito155tb is offline  
  (Post Link) post #5 of 5 Old 19-02-11
AO Member
 
Miss Alfa Romeo's Avatar
 
Join Date: Jan 2011
Location: Australia
Posts: 667
Images: 14
Welcome to AO!!
Miss Alfa Romeo is offline  
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Tags
156 , alfa , codes , fault

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome