High emissions - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 01-02-11 Thread Starter
Status: -
Join Date: Feb 2011
Location: United Kingdom
County: Fife
Posts: 2

Member car:

alfa 156

Warning 156 High emissions

My car is an Alfa romeo 156 W reg with 86000 miles.

It has just failed it MOT on high emissions they said it could be the Cat and lambda sensor. I don't want to go to the expense on a guess then find out it is something else. Did read on a forum it could be the temp sensor telling the ECU the car is still cold and over fuelling, it is running 70 Deg C.

MOT Cat closed loop results:-

Fast idle test
CO Level 3.47 %
HC Level 255 PPM
Lambda 0.91

Second fast idle
CO Level 3.05 %
HC Level 222 PPM
Lambda 0.91

Idle test
Speed 879 rpm
CO Level 6.02 %

Last edited by igby101; 02-02-11 at 11:37.
igby101 is offline  
Sponsored Links
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to AO.......you will get a better response to your problems in the 156 tech lounge....plenty of help and advice in there.....
Stu GTV is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:

Hope you get your 156 sorted ok
nigelread is offline  
(Post Link) post #4 of 5 Old 24-02-11 Thread Starter
Status: -
Join Date: Feb 2011
Location: United Kingdom
County: Fife
Posts: 2

Member car:

alfa 156

After checking plug gaps, air filter, air leaks, changed oil and filter emmissions a little better at test station. Observed test this time and noticed lambda reading not moving.
Bit the bullet and purchased a lambda sensor took for a retest and passed no problem. Also notice i am now getting much more miles out of a tank of fuel.
igby101 is offline  
Status: Benzina for Glory
AO Member
alfamito155tb's Avatar
Join Date: Feb 2011
Location: Portugal
County: Porto
Posts: 941
Images: 2
hey and welcome to AO hope you hget your 156 sorted out
alfamito155tb is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

156 , emissions , high

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome