147 thermostat - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 11-11-10 Thread Starter
Status: -
Join Date: Sep 2008
Location: United Kingdom
County: -
Posts: 4
147 thermostat

Hi guys and girls.

I have had my Alfa 147 for just over a year. The engine takes an absolute age to warm up, im talking almost to work before its at 90 degrees (journey time around 30 mins)is it the thermo thats kaput or something else ?

Thanks for any help in advance
1stalfa147 is offline  
Sponsored Links
Status: Married
Regional Representative
For East Midlands - AOEM
braddersR's Avatar
Join Date: Jul 2008
Location: United Kingdom
County: Leicestershire
Posts: 42,000
Images: 13
Hello there

pop ya question in this part of the site and you'll get a quicker response

Alfa 147, 156 & GT - Alfa Romeo Forum
braddersR is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:

Hope you get the problem sorted
nigelread is offline  
Status: -
AO Silver Member
Join Date: Aug 2003
Location: Bristol
Posts: 5,002
Sounds thermostatty...
mave is offline  
Status: -
AO Member
Join Date: Nov 2010
Location: United Kingdom
County: -
Posts: 18

Member car:

Alfa 147

im fitting a new thermostat on mine tomoz as it doesnt reach correct temp and it fluctuates
Trickydee is offline  
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to AO......
Stu GTV is offline  
Status: diem25.org
Club Member
Membro Premio
Elvis Presley's Avatar
Club Member Number: 59
Join Date: Aug 2006
Location: In a rockin good place
County: Memphis
Posts: 72,942
Images: 5

Member car:

A galleon



Do what it says......and good luck.

Welcome to AO
Elvis Presley is offline  
Status: - Update
Posts: n/a

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

147 , thermostat

« M9 MiTo | Hello... »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome