Immobiliser failure after battery change - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 19-09-10 Thread Starter
Status: -
Join Date: Sep 2010
Location: United Kingdom
County: Essex
Posts: 2

Member car:

alfa romeo 147

Hmmm Immobiliser failure after battery change

I own a 147 (52 plate) and the battery died last week. After fitting a new battery, the engine won't start. It's ticking over but reading 'immobiliser failure' on the dash. I tried disconnecting the battery negative for 20 mins, then tried again but still the same problem.

Is there a magic trick to fix it, or will I need to get an Alfa dealer out to my house to re-programme or re-code the keys etc?
hendersong is offline  
Sponsored Links
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:

Have a look in the 147 lounge or start a new thread.

Good luck
nigelread is offline  
Status: Misunderstood by many....
Temp Un-Registered
Join Date: Feb 2008
Location: South Wales
Posts: 28,471

Member car:

147 JTDm Ti

Good Morning......and Welcome to the A.O. Forum, I'm sure you will enjoy it here........
n13roy is offline  
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to AO.......
Stu GTV is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

battery , change , failure , immobiliser

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome