Newby from Aberdeen Scotland - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 02-09-10 Thread Starter
Status: -
Join Date: Sep 2010
Location: United Kingdom
County: Aberdeenshire
Posts: 2
Newby from Aberdeen Scotland

Well the nice fast and shiny sportwagon finally gave up on me yesterday resulting in a ride home on the breakdown wagon......

Been looking around site for few months since purchased car and finally took time to register ...HELLO

No we are begining the dig into the outer depths of an twinspark engine to see what has happened........

strange as now runs ... fairly smooth but with a loud thudding !! noise sounds metal / metal from area of belts ... compressions all ok and within 3psi each, belt ok .....

Well replacing all that moving stuff there this weekend then we will see what happens
udnyalfa is offline  
Sponsored Links
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to AO.....hope you sort the problem, plenty of help and advice in the tech lounges.....
Stu GTV is offline  
Status: Let me see your war face!
AO Gold Member
SpiderMonkey's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: South Yorkshire
Posts: 6,083
Images: 19
Welcome in, you'll love it in here
SpiderMonkey is offline  
Status: CTID
AO Silver Member
Mitogirl's Avatar
Join Date: Mar 2009
Location: United Kingdom
County: Gloucestershire
Posts: 3,791
Images: 8
Hi & welcome to AO :Bluesmile: , sorry you're having problems with your bella but hope they're not too serious.
Mitogirl is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:

Hope you get your Alfa sorted soon
nigelread is offline  
Status: Misunderstood by many....
Temp Un-Registered
Join Date: Feb 2008
Location: South Wales
Posts: 28,471

Member car:

147 JTDm Ti

Good Morning....and Welcome to the A.O. Forum, I'm sure you will enjoy it here.......
n13roy is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

aberdeen , newby , scotland

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome