alfa 156 jts engine management problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 02-09-10 Thread Starter
Status: -
Join Date: Sep 2010
Location: United Kingdom
County: Dorset
Posts: 3

Member car:

alfa 156 jts

alfa 156 jts engine management problem

Im at my witts end with my alfa, I have a jts 156 2003 that developes random faults. Last week it had a new radiator, today it is chugging like puffing billy. The fault it is now reading is a mass air flow sensor fault, previous to that it was showing lambda sensor fault which I cleared. The car is chugging, cutting out, smells of raw petrol fumes. I have disconnected the battery to help reset the ecu. Help I have spent over 4000 on this car and am at a loss. Should I replace the air flow sensor or could it be the wiring and not the sensor?. I would welcome any comments apart from sell it or set fire to it!!!
Many thanks

Last edited by callumaimee2; 02-09-10 at 09:59. Reason: spelling error
callumaimee2 is offline  
Sponsored Links
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to will get a much better response if you post your problem in the 156 tech lounge, here is just to introduce yourself...........
Stu GTV is offline  
Status: Let me see your war face!
AO Gold Member
SpiderMonkey's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: South Yorkshire
Posts: 6,083
Images: 19
Welcome in, you'll love it in here
SpiderMonkey is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:

Hope you get sorted ok
nigelread is offline  
Status: Misunderstood by many....
Temp Un-Registered
Join Date: Feb 2008
Location: South Wales
Posts: 28,471

Member car:

147 JTDm Ti

Good Morning....and Welcome to the A.O. Forum, I'm sure you will enjoy it here.......
n13roy is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

156 , alfa , engine , jts , management , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome