Alfa Romeo 147 Front Electric Window Problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 31-08-10 Thread Starter
Status: -
Join Date: Aug 2010
Location: United Kingdom
County: Antrim
Posts: 2

Member car:

Alfa Romeo 147

Alfa Romeo 147 Front Electric Window Problem


I own a 2002 Alfa Romeo 147. Today as it was hot when i got into the car i went to put the electric window down and the window fell down inside the door. I took the panels off the door and found that there is a small white clip that holds the window in place to a black bar and this was broken.

There is a kind of pulley system and i have tried to put the mechanism back in place however i am having great difficulty as i always seem to be slightly short after reconnecting everything. Was wondering if anyone had any tips as i am assuming that there must be an easy way of doing it.


Philip Johnston is offline  
Sponsored Links
Status: anniversary tomorrow !
AO Gold Member
alfamoment's Avatar
Join Date: Dec 2009
Location: United Kingdom
County: Neath Port Talbot
Posts: 11,159
Images: 21
Hi and welcome to AO just thought I would mention that if you post this request if the Tech lounge for 147s you will get a quicker and more accurate response, this is just for new peeps to say hello. click on Forums above then scroll down to Tech Lounges, you may find an answer without reposting.

Hello! and good luck with window.
alfamoment is offline  
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to AO.....hope alfamoment's advice has got you the answer you need......
Stu GTV is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:

Hope you get the window problem sorted
nigelread is online now  
Status: Misunderstood by many....
AO Platinum Member
n13roy's Avatar
Join Date: Feb 2008
Location: South Wales
Posts: 28,466

Member car:

147 JTDm Ti

Good Morning.....and Welcome to the A.O. Forum, I'm sure you will enjoy it here.......
n13roy is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

147 , alfa , electric , front , problem , romeo , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome