Timing Belt snaped - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 25-08-10 Thread Starter
Status: -
Join Date: Aug 2010
Location: United Kingdom
County: Inverclyde
Posts: 3
Timing Belt snaped

Hi, Just joined the group & a proud new owner of an Alfa Romero GT 1.9JTD 16V MJET:

Only have had the car 7 weeks with the intentions of changing the cam belt changed when the inevitable happened. Belt snapped, 57K on the clock. (2004).
As it happens only 2 valves need replaced. Now that the head is back on the car
The garage is having trouble setting up the timing. Has the garage missed something?
Any pointers would be great.

Still a happy Alfa owner, just want it back working.
KEV1404 is offline  
Sponsored Links
Status: CTID
AO Silver Member
Mitogirl's Avatar
Join Date: Mar 2009
Location: United Kingdom
County: Gloucestershire
Posts: 3,791
Images: 8
Hi Kev & welcome to AO, congrats on the GT :thumbsup: but sorry you're having problems, have a look in the GT tech lounge you should get some help in there.
Mitogirl is offline  
Status: Misunderstood by many....
Temp Un-Registered
Join Date: Feb 2008
Location: South Wales
Posts: 28,471

Member car:

147 JTDm Ti

Good Morning........and Welcome to the A.O. Forum, I'm sure you will enjoy it here........
n13roy is offline  
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to AO......sorry to hear of your problem, hope it has not spoiled the joy of Alfa ownership.....
Stu GTV is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:
nigelread is offline  
(Post Link) post #6 of 6 Old 26-08-10 Thread Starter
Status: -
Join Date: Aug 2010
Location: United Kingdom
County: Inverclyde
Posts: 3
Thanks for all the wellcomes, hopefully get the problem resolved soon
KEV1404 is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

belt , snaped , timing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome