Fan not turning on, problem wid sensors? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 15-05-10 Thread Starter
Status: -
Join Date: May 2010
Location: United Kingdom
County: Londonderry
Posts: 1
Fan not turning on, problem wid sensors?

Hi i just bought an Alfa Romeo 147 selespeed 2 litre engine on a 51 plate from a 'trade businessman' and on the first day i got it, the car started overheating because the fan was not coming on when the temp rose above 90. The AA tested the relay and that is fine so they said it must be the sensors (radiator cooling fan switch) but I do not know where they are located in my car. Where are the sensors located in my car? And how can i test to see if this is the problem? At the moment I am using a makeshift bridge, which turns my fan on and I leave it on while I'm driving and remove the makeshift bridge when I park up.

Also i put 10 petrol in the car and the gauge went up then it dropped drastically and its saying I am in reserve but i only drove around the corner. Does anyone know if there could be a problem with my petrol gauge and how can I test this please? Thankyou in advance
Stylah is offline  
Sponsored Links
Status: Misunderstood by many....
AO Platinum Member
n13roy's Avatar
Join Date: Feb 2008
Location: South Wales
Posts: 28,462

Member car:

147 JTDm Ti

Good Morning......and Welcome to the A.O. Forum, I'm sure you will enjoy it here........
n13roy is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

fan , problem , sensors , turning , wid

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome