156 Newbie - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 10-01-10 Thread Starter
Status: -
Join Date: Jan 2010
Location: United Kingdom
County: West Midlands
Posts: 3
156 Newbie

Hello group. My name's Dave, and I am a Selespeed owner.

2.0l TS 156 of 2001 vintage to be specific, in a light metallicy blue colour (sorry, not sure of the exact name). I was after a V6 sportwagon really, but ended up with a 2l saloon, but I only looked for 3 days so it's not all bad.

From the paperwork, it appears that it may have been a parallel import, but seems to be in UK spec, and maybe the sport pack or something? Dark grey Momo leather interior (nice, but I wish those seats were heated in our current climate!), 16" 5 spoke rims, sill trims and front fogs but no rear spolier. It's entirely standard apart from the head unit - rear offside window not working, occasional electrical faults (all the usuals I think!), but hey, it IS Italian.

First FWD car I've had for 5 years or so, and it handles pretty well - I was impressed. I'm sort of pining for my Scooby with all this snow though, you could drift that forever!

Though it is a very pretty car, it's currently in disgrace, as it won't start. The Selespeed pump did pack up, but I hit it with a hammer and now its fine. The same treatment didn't work with the starter though!

Nice to meet you all, safe travels
Logo is offline  
Sponsored Links
Status: Relaxed
AO Platinum Member
GJ's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Herefordshire
Posts: 17,658
Images: 13

Member car:

Spider S4

Welcome to AO
GJ is offline  
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hello and welcome to AO.... :HAPPY: ...sounds like your a pretty handy mechanic........hope you dont need the hammer too often...
Stu GTV is offline  
Status: Misunderstood by many....
Temp Un-Registered
Join Date: Feb 2008
Location: South Wales
Posts: 28,471

Member car:

147 JTDm Ti

Good Afternoon.......and Welcome to the A.O. Forum, I'm sure you will enjoy it here.......
n13roy is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:
nigelread is offline  
Status: -
tonyalfz's Avatar
Join Date: Jan 2010
Location: United Kingdom
County: West Yorkshire
Posts: 5

Member car:


welcome to the forum you can find pretty neat info when you have issues with your alfa

tonyalfz is offline  
Status: anniversary tomorrow !
AO Gold Member
alfamoment's Avatar
Join Date: Dec 2009
Location: United Kingdom
County: Neath Port Talbot
Posts: 11,159
Images: 21
Hello welcome and importantly .........................................

what size hammer was it ???????????????
alfamoment is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

156 , newbie

« intro | Hello ;) »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome