Hi All - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 10 Old 08-12-09 Thread Starter
Status: -
AO Member
Join Date: Dec 2009
Location: United Kingdom
County: Kent
Posts: 119

Member car:

Spider TS

Hi All

Just bought a 3 door 147 selespeed 2lt Tspark on a 53 plate in red. Delivery on Saturday. Can't wait.

Of course, I should have asked a variety of questions BEFORE I bought it but I just had to have it and than logic goes out the door.

So I ask the questions now:

As I quite enjoy doing my own servicing (oil, filters, brakes) is it possible to do this with this 147 or would you guys recommend an indy?

Is there a procedure to reset the service indicator? If not, what diagnostic reset tool is most suited?

Thanks for your input and looking forward to partake in the forum.
rnd76 is offline  
Sponsored Links
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:
nigelread is offline  
Status: -
AO Silver Member
Jackus's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: London
Posts: 2,375
Images: 36
Welcome to AO, congrats on the 147
Jackus is offline  
Status: - Update
Posts: n/a

all the best

Status: ...
AO Gold Member
Icheb's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Conwy
Posts: 10,009
Hi and welcome to AO
Icheb is offline  
Status: happier today
AO Silver Member
merlin's Avatar
Join Date: Jun 2006
Location: Kent
Posts: 2,437
Hello and Welcome
merlin is offline  
Status: Misunderstood by many....
AO Platinum Member
n13roy's Avatar
Join Date: Feb 2008
Location: South Wales
Posts: 28,471

Member car:

147 JTDm Ti

Good Morning......and Welcome to the A.O. Forum, I'm sure you will enjoy it here........
n13roy is offline  
Status: -
AO Silver Member
Jack 147's Avatar
Join Date: Nov 2008
Location: United Kingdom
County: Durham
Posts: 2,772

Member car:

Alfa 147 1.6 TS

Hello there. Welcome to AO
Jack 147 is offline  
Status: Owned! Pa to member Rayq81
AO Silver Member
Crazychick's Avatar
Join Date: Nov 2005
Location: United Kingdom
County: -
Posts: 4,456

Member car:

Zafira mostly.

Hello and welcome. My first alfa was a 147 selespeed.
Crazychick is offline  
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
Hi and welcome to AO.....
Stu GTV is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome