Hello!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 29-10-09 Thread Starter
Status: -
AO Member
Join Date: Jun 2009
Location: United Kingdom
County: Berkshire
Posts: 18

Member car:

Alfa 147


Hi to everyone out there!

this is all new to me, I bought my first Alfa about 6 months ago now; its a 147 2ltr selespeed. I have a a few little problems with it that I hope some people out there can help me with, but thought I would say hi first!!
evesc27 is offline  
Sponsored Links
Status: Happy
AO Silver Member
WishfulThinker's Avatar
Join Date: Jul 2009
Location: United Kingdom
County: Greater Manchester
Posts: 5,263
Images: 14
Hello and welcome. I am sure the 147 technical forum will be full of helpful people.
WishfulThinker is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:
Congrats on the 147
nigelread is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome