New to the forum - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 28-09-09 Thread Starter
Status: -
Join Date: Sep 2009
Location: United Kingdom
County: Cheshire
Posts: 6
New to the forum

Hi all,

I have been driving a lovely 147 1.9 JTD Lusso for teh last 18 months and thoroughly enjoyed it. Just started running into a few problems and want to seek advice on here.
MCJones is offline  
Sponsored Links
Status: Married
Regional Representative
For East Midlands - AOEM
braddersR's Avatar
Join Date: Jul 2008
Location: United Kingdom
County: Leicestershire
Posts: 42,000
Images: 13
Hello and welcome to AO ... hope you get sorted out
braddersR is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:
i'm sure you will find all the info you need on AO
nigelread is offline  
Status: ...
AO Gold Member
Icheb's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Conwy
Posts: 10,009
Hello and welcome to AO

Enjoy and have fun
Icheb is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome