selespeed stuck in 3rd gear - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 28-09-09 Thread Starter
AO Member
trevb007's Avatar
Join Date: Feb 2009
Location: United Kingdom
County: Londonderry
Posts: 14
Images: 1
Help selespeed stuck in 3rd gear

hi people,
my w reg 156 2.0 ts selespeed is stuck in 3rd gear. i was at the bank, when i got back into the car i turned the key & nothing - just kept showing & flashing 3 in gear selection panel.
i got a tow, she was very jumpy at slow speed (prod cause she was stuck in gear) when the car got up to 15 - 20 mph the engine kicked in & i was able to drive the car to a garage (albeit attached to a rope only 10 foot behind my mates land crusier!!) Im not sure if the pump is working when the door is open - the sele oil level is full. What could it be??

Any help would be great.

trevb007 is offline  
Sponsored Links
Status: -
AO Gold Member
Join Date: Aug 2007
Posts: 7,040
Welcome to AO Post your query in the tech lounge, hope you get it sorted.
Spider95 is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Hello and Welcome :wave:
Hope you get your 156 sorted soon
nigelread is offline  
Status: ...
AO Gold Member
Icheb's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Conwy
Posts: 10,009
Hello and welcome to AO

Enjoy and have fun
Icheb is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

3rd , gear , selespeed , stuck

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome