Hi Everyone - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 25-09-09 Thread Starter
Status: The V6 lives! Phew.
AO Member
rhysenna's Avatar
Join Date: Sep 2009
Location: United Kingdom
County: West Yorkshire
Posts: 135
Images: 5

Member car:

Alfa 156 2.5

Hi Everyone

Hi. Just joined up. I have a 1999 156 2.5 but unfortunately the cambelt or tensioner failed a couple of weeks ago and is now sat looking very sorry for itself! Thinking of dropping the 3.2 in. Does anyone have any experience of this?
rhysenna is offline  
Sponsored Links
Status: brakes, mot, belts, paint.. done!
AO Member
Alfa_One's Avatar
Join Date: Jun 2009
Location: United Kingdom
County: Glasgow
Posts: 115
Images: 11

Member car:

2002 156 2.0 JTS

Hi and welcome
Alfa_One is offline  
Status: ...
AO Gold Member
Icheb's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Conwy
Posts: 10,009
Hello and welcome to AO

Enjoy and have fun
Icheb is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome