Spider T.Spark cutting out - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 19-05-09 Thread Starter
Status: spiderman
AO Member
Join Date: May 2009
Location: United Kingdom
County: Isle of Wight
Posts: 13

Member car:


Spider T.Spark cutting out

Has anyone experienced the cutting out of their spider when slowing down, usually coming upto roundabouts etc. I thought I'd solved it by fitting a new air filter, this seemed to cure it for about 4 months. The rev counter bounces around like crazy from 0 to 1000 rpm, sometimes it settles to idle but occassionally cuts out which means losing power to steering and brakes. I guess it might be an electrical/computer fault does anyone have any ideas?

Thanks for reading this.

Austin Healey is offline  
Sponsored Links
Status: -
AO Silver Member
abarth sav's Avatar
Join Date: Nov 2008
Location: United Kingdom
County: Essex
Posts: 2,690

Member car:

all alfas

Re: Spider T.Spark cutting out

Hi and welcome to the AO forum
abarth sav is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

cutting , spider , tspark

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome