New to the Alfa Romeo Forum - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 03-05-09 Thread Starter
Status: -
Join Date: May 2009
Location: United States
County: Washington
Posts: 1

Member car:

1990 Spider

New to the Alfa Romeo Forum

Hello All,

Although I'm not new to Alfa Romeo ownership I am new to this forum. I look forward to being an active participant for many years to come.

The reason for my post today is to ask for some help with a recent problem my 1990 Spider (Quadrifoglio) is experiencing. I've owned this car for a little over 6 years and have never had a problem. Unfortunately, last week the car began to shake when starting out and at low speeds. The entire car shakes but feels like it's originating in the drivetrain. When the car is out of gear or the clutch is engaged the shaking stops. If I accelerate the shaking again stops. If anyone has experienced a similar problem could you please give me some guidence on what is causing it and what I need to do to fix it so I can get out and enjoy the summer that has finally arrived in Washington state

Thank you for your help.

webdude is offline  
Sponsored Links
Status: -
AO Silver Member
abarth sav's Avatar
Join Date: Nov 2008
Location: United Kingdom
County: Essex
Posts: 2,690

Member car:

all alfas

Re: New to the Alfa Romeo Forum

Hi and welcome to the AO forum
abarth sav is offline  
Status: -
AO Member
LUSSO 916's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: South Yorkshirem
Posts: 458
Images: 3
Re: New to the Alfa Romeo Forum

Hi & welcome to AO.Judder could be caused by the clutch plate shims that are in the centre of the ferodo discs,they break & allow the 2 plates to move.Hope you get sorted.
LUSSO 916 is offline  
Status: -
AO Gold Member
Join Date: Aug 2007
Posts: 7,040
Re: New to the Alfa Romeo Forum

Hope you get it fixed Grant. Post some pics
Spider95 is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: New to the Alfa Romeo Forum

Hello and Welcome :wave:
Yup pics please
nigelread is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,036
Images: 2
Re: New to the Alfa Romeo Forum

Hi Grant post up your question in the Classics lounge and welcome to AO.
classicgal93 is offline  
Status: -
AO Platinum Member
SPPalfa's Avatar
Join Date: Nov 2007
Location: United Kingdom
County: Newport
Posts: 16,125
Images: 7
Re: New to the Alfa Romeo Forum

Hello and welcome to AO

Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
SPPalfa is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

alfa , forum , romeo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome