hello - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 26-04-09 Thread Starter
Status: -
AO Member
Join Date: Apr 2009
Location: United Kingdom
County: Staffordshire
Posts: 18

Member car:

***** romeo 147


I have just purchased a 2002 plate 147. I havn't had much luck with it so far. As i was driving after the purchase the systems control failure light flashed on and went out at varied intervals. The car still drove ok so i carried on with my journey. Then out of nowhere the car lost power. I tried starting but it wouldn't go. I let it sit for a while and tried again this time it coughed and spluttered but started to tick over although not smooth at all. If i try to rev it more than idle it gives out white smoke. The oil level was low but just above the minimum. Please can anyone tell me what they might think the problem could be. I am worried about getting ripped off if i take it to a dealers.
akki is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Re: hello

Hi and welcome to AO. Lots of help in the tech section, good luck with it.
classicgal93 is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: hello

Hello and Welcome :wave:
Good luck with your 147
nigelread is offline  
Status: -
AO Platinum Member
SPPalfa's Avatar
Join Date: Nov 2007
Location: United Kingdom
County: Newport
Posts: 16,125
Images: 7
Re: hello

Hello and welcome to AO

Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
SPPalfa is offline  
Status: -
AO Silver Member
abarth sav's Avatar
Join Date: Nov 2008
Location: United Kingdom
County: Essex
Posts: 2,690

Member car:

all alfas

Re: hello

Hi and welcome to the AO forum
abarth sav is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome