Yet another Motor System Control Failure ....Help! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 16-04-09 Thread Starter
Status: -
Join Date: May 2008
Posts: 2

Member car:

Alfa 156 2.) JTS

Yet another Motor System Control Failure ....Help!

Dear fellow Alfa owners,

I own an '03 alfa 156 2.0 JTS (Facelift - i.e. "old 156 shape on the outside but new dash etc on inside ...) that I bought from SGT in Taplow. Enjoyed the driving for 5 years - but in the 18m the Motor Control System Failure (MSCF) has been bane of my life.

I have been to three different garages in the past year to get the problem fixed - Alfarama, Alfaman and SGT - without any joy. A brief history of my woes to date:

-MSCF - lambda sensor - replaced.
-MSCF - two days later - another lambda sensor - replaced.
-MSCF - unknown fault, garage rejigged some wiring.
-MSCF - alternator - replaced
-MSCF - Battery - replaced
-MSCF - loose wiring - "cleaned and tightened connections"
-MSCF - loose wiring again - same treatment + plus just had the 6 year major service and timing belt replaced.
-MSCF - two days after the service etc - now the engine skips a beat when I accelerate hard ("misfiring?") and the beep beep beep comes on frequently.

I have followed some of the posts on this topic and this seems to be an increasingly frequent problem. I wonder if there is anything I can to do to resolve this once and for all?

Also, which oil is recommended for 156 JTS - semi or fully synthetic selenia? My engine tends to go through approx 10L/year - is this excessive?
Sonata is offline  
Sponsored Links
Status: Bored waiting for the Giulia
AO Member
GCDBONES123's Avatar
Join Date: Oct 2008
Location: United Kingdom
County: Nottinghamshire
Posts: 841
Images: 1
Re: Yet another Motor System Control Failure ....Help!

I had a 2.0JTS for 5 years and many happy miles and i feel your pain on the engine warning light. Could type a small essay here but wont. Here goes on the potted version.
1) Oil - Its Selenia 10W 60 accoridng to AR. ********* says I. Give it a decent fully synthetic 0w40 or similar (mobil 1 will do nicely) and it will thrive on it. If your keeping the car stick to fully synthetic.
2) My advice is a piece of black duck tape over the warning light Not being flippant here but you can go through a lot of cash, time and patience chasing that engine warning light. Learn to ignore it is my sage advice. (unless theres an obvious problem with the car) Normally lambda sensor or air flow sensor fault but due to their design and location with excessive heat etc they go wrong a LOT. Can you sort the problem - undoubtedly. Will it stay sorted, yes for a day, a week, a month or a year depending on how your luck holds. Im sure lots of people will disagree so if you want to sort it find a decent Alfa specialist and get your wallet ready. Otherwise drive the car and enjoy, its a great engine - much better than the 2.2 GM unit I replaced it with in the 159.

56 1.8TS Lusso, 156 2.0JTS Selespeed Veloce, 159 2.2JTS TI, Mito 1.4TB 120Veloce, 159 1750 TBI TI.

Last edited by GCDBONES123; 16-04-09 at 12:04.
GCDBONES123 is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: Yet another Motor System Control Failure ....Help!

Hello and Welcome :wave:
nigelread is offline  
Status: Spider's away for winter
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,057
Images: 2
Re: Yet another Motor System Control Failure ....Help!

Hi I hope you get some answers to this, good luck with it.
classicgal93 is offline  
Status: - Update
Posts: n/a
Re: Yet another Motor System Control Failure ....Help!

Hello :wave: Welcome to AO

Your best bet for advice is to ask in the 156 section of the forum - here you'll really only get hellos

Follow the link and good luck

Alfa 147, 156 & GT - Alfa Romeo Forum
Status: -
AO Member
Join Date: Mar 2007
Location: United Kingdom
County: -
Posts: 92
Re: Yet another Motor System Control Failure ....Help!

The latest symptoms you describe (accelerate hard, miss a beat) sound like the symptoms I had on the JTS - an intermittent coil failure.

My solution - get a diagnostic programme for my laptop, read the codes myself, swap the coils to see that the misfire moved from one cylinder to another, buy a new coil and fit it myself (five minute job).

12000 miles later, and no MCSF warnings.

You really need to find out what the error codes are that are triggering the MCSF.

(oh yes... welcome to the Forum)
furryman is offline  
Status: -
AO Member
Join Date: Apr 2009
Location: United Kingdom
County: Down
Posts: 59
Re: Yet another Motor System Control Failure ....Help!

white smoke is coolant ithink, check for leaks
DKCLEANS is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

control , failure , motor , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome