hello - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 01-04-09 Thread Starter
Status: -
Join Date: Apr 2009
Location: United Kingdom
County: Lancashire
Posts: 1

Member car:



hello iam new to the site be kind i can answer tyre exhaust and brake problems but am not very good at engine diognostics i need help with an alfa 145 that wont rev when the maf sensor is connected please help
iantg25 is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Re: hello

Hi Ian welcome to AO. Give our tech section a look through, good luck with it.
classicgal93 is offline  
Status: -
AO Platinum Member
SPPalfa's Avatar
Join Date: Nov 2007
Location: United Kingdom
County: Newport
Posts: 16,125
Images: 7
Re: hello

Hello & welcome to AO

Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
SPPalfa is offline  
Status: -
AO Silver Member
abarth sav's Avatar
Join Date: Nov 2008
Location: United Kingdom
County: Essex
Posts: 2,690

Member car:

all alfas

Re: hello

Hello, welcome to the AO forum
abarth sav is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: hello

Hello and Welcome :wave:
nigelread is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

« Hi Everyone | Hi »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome