Hello all... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 29-03-09 Thread Starter
Status: -
Join Date: Mar 2009
Location: United Kingdom
County: Northamptonshire
Posts: 1
Hello all...

Hi all, I am now on my second Alfa.. The first an S reg 156 2.5 V6 in Africa Grey, loved that car but by god was it thirsty.. Plus we had our fair share of trips to my local Alfa Garage for a special brand of wallet liposuction as only Alfa Dealerships can.. Good times.. Just for the love of driving and to prove to all my friends that the love for Alfa Romeo cars goes before all common sense, last year I moved on to my second Alfa.. My Red 03 Reg 147 1.9 16v Jtd Multijet.. Its a joy to drive and still makes me smile when I leave work..

It is playing up at the moment but am working on the problem.. It seems to be either the EGR Valve or perhaps the MAF sensor or worse a combination of both, I've had plenty of expensive experience with MAF sensor problems at the hands of my old car..

Anyways.. I've read quite a few posts on here regarding these problems and the people on here that have given advice I can only thank for helping point me in the right direction..

If anyone is interested I have a copy of Alfadiag and have been using this to help diagnose the problem.. perhaps I should be directed elsewhere (i.e another forum) but I would like to share my thoughts and findings and discuss with someone more experienced with myself..

Maverick_0022@ is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Re: Hello all...

Hi Maverick welcome to AO. Have a look in our tech section.
classicgal93 is offline  
Status: -
AO Silver Member
abarth sav's Avatar
Join Date: Nov 2008
Location: United Kingdom
County: Essex
Posts: 2,690

Member car:

all alfas

Re: Hello all...

Hi and welcome to the AO forum
abarth sav is offline  
Status: - Update
Posts: n/a
Re: Hello all...

hello and welcome to ao
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: Hello all...

Hello and Welcome :wave:
nigelread is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

« alfa Noob | Hdc »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome