2000 156 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 15-03-09 Thread Starter
Status: -
Join Date: Mar 2009
Location: United Kingdom
County: Edinburgh
Posts: 4

Member car:


2000 156


I have a 2000 156 Veloce. Love the car. After just getting it serviced and an MOT an orange warning light in the shape of an engine has appeared in the top right corner beside the battery and oil warning lights. I've looked through the handbook countless times,but can't find anything to tell me what it is.Can anyone advise?

kingdomofdalria is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,043
Images: 2
Re: 2000 156

Hi King welcome to AO. check out our tech section Alfa 147, 156 & GT - Alfa Romeo Forum
classicgal93 is offline  
Status: - Update
Posts: n/a
Re: 2000 156

hello and welcome to alfa owner
Status: -
AO Silver Member
abarth sav's Avatar
Join Date: Nov 2008
Location: United Kingdom
County: Essex
Posts: 2,690

Member car:

all alfas

Re: 2000 156

Hello and welcome to the AO forum
abarth sav is offline  
Status: - Update
Posts: n/a
Re: 2000 156

welcome to AO..

all the best...


Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

156 , 2000

« hello | Hi »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome