Hello to the Forum - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 27-02-09 Thread Starter
Status: -
Join Date: Nov 2008
Location: United Kingdom
County: Wiltshire
Posts: 3

Member car:

147 Selespeed

Hello to the Forum

Hi Everyone,

I joined not long ago but this is the first opportunity to post, although I found very helpful information recently on the problems with selespeed.

I have a not-too-temperamental 2.0 litre 147 in Russo red first registered in 2002. The only real problem was a timing belt failure at about 60,000 miles ( I bought the car at 35,000 having been assured it had been changed - the service record said it had!). Since the top end re-build it's been fine.........it's now done about 77,000 miles.

Temperamental maybe, but I love it.


Grumpy Eric is offline  
Sponsored Links
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: Hello to the Forum

Hello and Welcome :wave:
nigelread is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Re: Hello to the Forum

Hi Eric welcome to AO.
classicgal93 is offline  
Status: - Update
Posts: n/a
Re: Hello to the Forum

Hello and welcome to AO :wave:

There are a couple of other sections of the forum which might interest you:

Alfa Romeo Meets & Events - Alfa Romeo Forum

Technical & Vehicle Assistance - Alfa Romeo Forum

Any problems? Email me at paintergirl@alfaowner.co.uk

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


« Hi | hey »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome