Indicating - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 06-01-09 Thread Starter
Status: -
AO Member
Join Date: Jan 2009
Location: New Zealand
County: Wellington
Posts: 10

Member car:



Hi, I have a 156 and occasionaly the indicators stop working. No sound and no blinking dash light. This may come right within a few moments or it may not. Any suggestions to repair this.
texastwo is offline  
Sponsored Links
Status: -
AO Platinum Member
SPPalfa's Avatar
Join Date: Nov 2007
Location: United Kingdom
County: Newport
Posts: 16,125
Images: 7
Re: Indicating

Hello and welcome to AO - post your question in the 156 tech lounge

Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
SPPalfa is offline  
Status: - Update
Posts: n/a
Re: Indicating

hello and welcome to ao.
Status: - Update
Posts: n/a
Re: Indicating

Hello and welcome to AO :wave:

There are a couple of sections of the forum which might interest you:

Alfa Romeo Meets & Events - Alfa Romeo Forum

Technical & Vehicle Assistance - Alfa Romeo Forum

Any problems? Email me at
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: Indicating

Hello and welcome :wave:
nigelread is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: Indicating

Welcome to AO

Post your query here please: Alfa 147, 156 & GT - Alfa Romeo Forum
BigFoot is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,036
Images: 2
Re: Indicating

Hi and welcome to AO
classicgal93 is offline  
Status: Married
Regional Representative
For East Midlands - AOEM
braddersR's Avatar
Join Date: Jul 2008
Location: United Kingdom
County: Leicestershire
Posts: 41,996
Images: 13
Re: Indicating

hello and welcome to AO.....
braddersR is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome