Hello everyone - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 20-12-08 Thread Starter
Status: -
davis222's Avatar
Join Date: Dec 2008
Location: United Kingdom
County: Wiltshire
Posts: 6

Member car:


Hmmm Hello everyone

Hi, I've just joined this forum due to problems with my 156. I say problems, the problem is the fact i went through a large puddle and now seemed to have caused what i believe is called hydrolock???
After the car cut out in the puddle (looked more like a Lake) I pushed her out and eventually got her towed home. I removed all 8 spark plugs, air pipes etc in order to let her dry out (this was last saturday (13TH Dec)) now the 22nd, all looks dryish inside but when i try to start it with or without the spark plugs to clear any water in the engine it just makes a mad sounding, loud clicking noise and all the lights on the dashboard flash on and off frantically. I have started stripping her down but between me and my mate we make maybe half a decent mechanic so would really appreciate any advice anyone can offer.
Its a 156 2.0JTS 2001. if that makes any difference.
Cheers in advance
davis222 is offline  
Sponsored Links
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: Hello everyone

Hello and Welcome
Post your question here
Alfa 147, 156 & GT - Alfa Romeo Forum
you will get a better response
nigelread is offline  
Status: - Update
Posts: n/a
Re: Hello everyone

Hello and welcome to AO :wave:

There are a couple of sections of the forum which might interest you:

Alfa Romeo Meets & Events - Alfa Romeo Forum

Technical & Vehicle Assistance - Alfa Romeo Forum

Any problems? Email me at paintergirl@alfaowner.co.uk
Status: Spider's away for winter
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,057
Images: 2
Re: Hello everyone

Hi Davis welcome to AO. I hope you get her sorted quickly.
classicgal93 is offline  
Status: - Update
Posts: n/a
Re: Hello everyone

hello and welcome to ao.

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome