I47 Key Problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 9 Old 09-12-08 Thread Starter
Status: -
Join Date: Sep 2007
Posts: 1

Member car:

147 2.0

I47 Key Problems


I've had a 6 year old 147 for about 18 months now, its a 2.0 and I really love it, but and have had a series of key/lock problems...

In the summer I replaced the battery in one of my keys and afterwards it wouldn't start the car giving a 'code' fault in the display. I had to go back home to get the spare key to start the car, I haven't dared try and use the first key since.

Recently the 'spare' key Ive been using since has started flashing the small red light briefly when I use, and often it takes several attempts to open the car. Then the last time I tried using the car the electric windows wouldn't work and the display kept flashing.

I know I must change the battery in the 'spare' key, but is the low key battery problem at all connected the electric windows not working????

Any help greatly appreciated. I can give clarifications if this doesn't make sense.

Andrew_Brooks is offline  
Sponsored Links
Status: Relaxed
AO Platinum Member
GJ's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Herefordshire
Posts: 17,658
Images: 13

Member car:

Spider S4

Re: I47 Key Problems

Welcome to AO

Post your question in the Technical lounge

Alfa 147, 156 & GT - Alfa Romeo Forum

and I'm sure someone will help
GJ is offline  
Status: -
Join Date: Dec 2008
Location: United Kingdom
County: Suffolk
Posts: 4
Re: I47 Key Problems

hi andrew i also have a 147 an had key fob issues. when changing the battery it doesnt matter how long it takes as with some key fobs they state a given time to replace.i found this out when i stripped my key fob down to resolder the micro switches back on the circuitboard. i left it overnight with no battery in in bits on my kitchen worktop.my key also got temprimental an worked only when it felt like it- this was all down to the micro switches having hairline cracks in the solder on the boards so i resoldered and now there fine. alternativly you can buy new switches which i found someone selling on ebay a few months ago. hope this helps but just ask if you need more assitance
alfasquirrel is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Re: I47 Key Problems

Hi A welcome to AO.
classicgal93 is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: I47 Key Problems

Welcome and good luck
BigFoot is offline  
Status: - Update
Posts: n/a
Re: I47 Key Problems

hello and welcome to ao.
Status: To think I used to have a room here
AO Silver Member
RichGTV's Avatar
Join Date: Aug 2008
Location: United Kingdom
County: Greater London
Posts: 4,955
Images: 16

Member car:


Re: I47 Key Problems

Welcome to AO and good luck with the key issue
RichGTV is offline  
Status: - Update
Posts: n/a
Re: I47 Key Problems

Hello and welcome to AO :wave:

There are a couple of sections of the forum which might interest you:

Alfa Romeo Meets & Events - Alfa Romeo Forum

Technical & Vehicle Assistance - Alfa Romeo Forum

Any problems? Email me at paintergirl@alfaowner.co.uk
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: I47 Key Problems

Hello and welcome
nigelread is online now  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

i47 , key , problems

« Hi | Hello everyone »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome