Introduction - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 05-12-08 Thread Starter
Status: -
Join Date: Dec 2008
Location: South Africa
County: Mpumalanga
Posts: 4
Not Happy Introduction

Hi! My name is Johan van der Merwe, I'm 31 Years old and I'm driving a 2002 Alfa Romeo 2.0 147 Selespeed.
I'm staying in South Africa in the North West province near the well known Kingdom of Pleasure, better known as Sun City.
As a hobby I do customizing including custom spray painting on vehicles.
My Opel Astra were featured in issue 21 of Speed & Sound magazine.
At the moment I am a plant electrician at one of Xstrata's Chrome mines.
I am married Sarie and have two daughters, Canté (4) and Tasha (1).

I would like to know if there is someone who can assist me with the problem I have with my car at the moment? I can't put my finger on it but I think my clutch is on its way out.
When I engage first and second gear the display "1 or 2" depending on which gear I select is blinking, and sometimes struggles to engage gears.
I adjusted the clutch a little and the problem was gone for about a month before it started again. Today I adjusted it some more but struggled to get it right. The other thing I thought about was that it could be low battery power as from the time I installed my sound system with a 3-Farad cap I hear the alternator belt screams on startup until the cap is charged.
If anyone had a similar problem, I would like to hear from you.

Chat to you soon.
Hitler007 is offline  
Sponsored Links
Status: -
AO Silver Member
Drivers71's Avatar
Join Date: May 2005
Location: United Kingdom
County: West Midlands
Posts: 1,239
Images: 450
Re: Introduction

Hello and welcome Johan.
The 156 forums would be a good place to search for the answer to your clutch problem.
Drivers71 is offline  
Status: - Update
Posts: n/a
Re: Introduction

hello and welcome to ao.
try Alfa 147, 156 & GT - Alfa Romeo Forum
for technical assistance.
Status: Struggling on
AO Gold Member
Brickman's Avatar
Join Date: Oct 2006
Location: United Kingdom
County: West Yorkshire
Posts: 11,614
Images: 26
Re: Introduction

Hello :Hello:
Brickman is offline  
Status: - Update
Posts: n/a
Re: Introduction

Hello and welcome to AO :wave:

There are a couple of sections of the forum which might interest you:

Alfa Romeo Meets & Events - Alfa Romeo Forum

Technical & Vehicle Assistance - Alfa Romeo Forum

Any problems? Email me at
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: Introduction

Hello and Welcome
nigelread is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,052
Images: 2
Re: Introduction

Hi enjoy the site.
classicgal93 is offline  
Status: Zoe FTW
AO Rosso Alfa Member
baby278278's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Essex
Posts: 46,602
Images: 49
Re: Introduction

Hello and Welcome to the forum

I hope you enjoy your stay !
baby278278 is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


« hello! | Hello »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome