terminator61 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 05-11-08 Thread Starter
Status: -
Join Date: Nov 2008
Location: United Kingdom
County: Northamptonshire
Posts: 1

Member car:

159 sportswagon

Hmmm terminator61


I have just joined the forum and in brief have owned my first ***** romeo for approximately 6 months now 159 Sports wagon 1.9 jtdm. I have had a few small issues which have been remidied the later being the hill descent control and picked the car up yesterday morning. On returning to the car later on in the day to go home from work I was confronted by a horrible grinding and squealling sound coming from the steering column. My car had to lifted and taken to the garage.

Has anyone else experienced the same of similar issues? If so what was the outcome. Fortunately the car is still under warranty...... .
terminator61 is offline  
Sponsored Links
Status: -
AO Platinum Member
SPPalfa's Avatar
Join Date: Nov 2007
Location: United Kingdom
County: Newport
Posts: 16,125
Images: 7
Re: terminator61

Hello and welcome to AO - post your question in the 159 tech lounge

Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
SPPalfa is offline  
Status: Married
Regional Representative
For East Midlands - AOEM
braddersR's Avatar
Join Date: Jul 2008
Location: United Kingdom
County: Leicestershire
Posts: 42,040
Images: 13
Re: terminator61

hello and welcome to Ao.........
braddersR is offline  
Status: - Update
Posts: n/a
Re: terminator61

Hi and welcome to AO :wave:

The place you need to post your question is here Alfa 159, Brera & 946 Spider - Alfa Romeo Forum

*whispers* and you have an Alfa
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: terminator61

Hello and welcome
nigelread is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: terminator61

Welcome to AO
BigFoot is offline  
Status: Spider's away for winter
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,057
Images: 2
Re: terminator61

Hi welcome to AO.
classicgal93 is offline  
Status: Still Happily Married..........
AO Platinum Member
dpat's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Cheshire
Posts: 32,403
Images: 20
Re: terminator61

welcome to AO
dpat is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome