engine/oil leak problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 29-10-08 Thread Starter
Status: -
Join Date: Oct 2008
Location: United Kingdom
County: Cornwall
Posts: 1
Help engine/oil leak problem

Hi all, i seem to have a serious oil leak, which seems to be coming from somewhere behind the cambelt cover. Am thinking maybe crankseal? Anybody got any ideas pls?
jabbathemutt is offline  
Sponsored Links
Status: Still Happily Married..........
AO Platinum Member
dpat's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Cheshire
Posts: 32,403
Images: 20
Re: engine/oil leak problem

Try posting in the 146 model lounge, you'll get a better resonse

welcome to AO
dpat is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: engine/oil leak problem

Welcome to AO

Please post your query here: Alfa 145 & 146 - Alfa Romeo Forum
BigFoot is offline  
Status: Spider's away for winter
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,057
Images: 2
Re: engine/oil leak problem

Hi I hope you get her fixed up quickly.
classicgal93 is offline  
Status: -
AO Platinum Member
SPPalfa's Avatar
Join Date: Nov 2007
Location: United Kingdom
County: Newport
Posts: 16,125
Images: 7
Re: engine/oil leak problem

Hello and welcome to AO

Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
SPPalfa is offline  
Status: Married
Regional Representative
For East Midlands - AOEM
braddersR's Avatar
Join Date: Jul 2008
Location: United Kingdom
County: Leicestershire
Posts: 42,040
Images: 13
Re: engine/oil leak problem

hello and welcome to AO....
braddersR is offline  
Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Re: engine/oil leak problem

Could indeed be the front crankshaft lipped seal, behind the pulley. Remove the cover to inspect with a good light source, with the motor running if necessary.:
zulu ferret is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

engine or oil , leak , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome