My 'hello post' - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 9 Old 19-09-08 Thread Starter
Status: needs more tools
AO Member
Sh33p's Avatar
Join Date: Sep 2008
Location: South Africa
County: Gauteng
Posts: 68
Images: 5

Member car:

2003 147 2.0TS

My 'hello post'


I've been an Alfa lover since high-school... and my little Golf II was stolen a few weeks ago. I have bought a 2003 Alfa 147 2.0 T.Spark 5 dr - no selespeed though. The car drives great... just a few problems.

Cant switch the ASR off - pressing the button does nothing
Drivers side front fog light doesn't light up
and... it seems that the drivers electric window control broke sometime in the past - and was replaced by the 3door version. As such, cant open or close the rear windows (apart from the key holding lock/unlock method) as the child-lock is permanently on!
I'm going to take it back to the dealer later today to see what they say about those... as they claimed that all the electrics were working.

Does anyone have a soft-copy of the Owners' Manual? Mine didn't come with one

Sh33p is offline  
Sponsored Links
Status: -
AO Platinum Member
SPPalfa's Avatar
Join Date: Nov 2007
Location: United Kingdom
County: Newport
Posts: 16,125
Images: 7
Re: My 'hello post'

Hi Greg - welcome to AO - post your questions in the tech lounge and some one will be along to help

Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
SPPalfa is offline  
Mark Alfa
Status: - Update
Posts: n/a
Re: My 'hello post'

Hello and welcome to AO Greg
Status: -
AO Platinum Member
GTA Jim's Avatar
Join Date: Apr 2007
Posts: 14,575
Images: 3

Member car:

147 GTA

Re: My 'hello post'

Hi Greg, welcome

I hate the sillyspeed your best off without it IMO.
GTA Jim is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: My 'hello post'

Hello and welcome
nigelread is offline  
Status: - Update
Posts: n/a
Re: My 'hello post'

welcome to AO Greg and all the best...

Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Re: My 'hello post'

Hi Greg welcome to AO.
classicgal93 is offline  
Status: -
AO Gold Member
rammy's Avatar
Join Date: Feb 2007
Location: burton on trent
Posts: 7,719
Re: My 'hello post'

Hello and welcome to AO.
rammy is offline  
Status: -
AO Member
phll14's Avatar
Join Date: Aug 2008
Location: United Kingdom
County: Wrexham
Posts: 867
Re: My 'hello post'

Hi there & Welcome!

LOVE Selespeed Just treat her right...
phll14 is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome