1999 2l 156 T-spark - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 08-09-08 Thread Starter
Status: -
AO Member
THE_NIK's Avatar
Join Date: Sep 2008
Location: Ireland
County: Kildare
Posts: 119
1999 2l 156 T-spark

Hi all just picked up a 99 156 2l t-spark at the weekend. i have been wanting one for a while. but im normally broke. i wouldnt be considered a big spender got it for 1500 euro with only 60k on the clock with some small issues as expected. i was hoping i could get some feedback as i am not very technical and worried due to scare mongery by uneducated people. i was not looking for an exremly reliable car i was looking for a particular car and as i am not driving for work any more i decided to go with my heart. please any advice would be greatly appriciated

1. back driver side electric window not working. from front or back can here the click of switch dont know if its making contact but window will not go up or down. open about 1/4 way so not secure have some tape holding it in position so no one will get ideas

2. noticed large amount of oil under the car. after i bought it i freaked out at first but it turned out to be a loose sump bolt i tightned it and mentioned it to my father in law ex-mechanic 20 of years + he got under the car and over tightned the bolt now its dripping slowly but persistantly i belive he over tightned it . Which is most likly a rung bolt or a rung sump threads dont want to order a bolt and loose all my oil if its most likely the sump. how much in cash is involved in a sump replacement.

3. over heating in traffic. car is fine when moving temprature as low as (60) but when i was bringing it home i got stuck in traffic the gauge went up as far as 110. i got worried so i stopped and checked the oil which is over full. Is this within normal operating tempratures.

4. front suspension squeeks over speed bumps and rough ground not a huge amount of noise but worried as i hear front suspension is a nightmare and expensive to fix.

5. radio keeps beeping single beep every few minutes when cd or radio. radio will not pick up stations or turn off when engine is turned off.

Last edited by THE_NIK; 08-09-08 at 15:13. Reason: spelling
THE_NIK is offline  
Sponsored Links
Status: -
AO Member
phll14's Avatar
Join Date: Aug 2008
Location: United Kingdom
County: Wrexham
Posts: 867
Re: 1999 2l 156 T-spark

Hi there and welcome!

Just post your specific problems in their relevant lounges and I'm sure you'll get a better response!

There are a lot of very knowledgable people on this site.

I'm not one of them!
phll14 is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,043
Images: 2
Re: 1999 2l 156 T-spark

Hi and welcome to AO I see you've posted your questions in the tech lounge, good luck with them.
classicgal93 is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: 1999 2l 156 T-spark

Welcome to AO

Good luck with the problems
BigFoot is offline  
Mark Alfa
Status: - Update
Posts: n/a
Re: 1999 2l 156 T-spark

Hello and welcome to AO. Hope you get it sorted ok

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

156 , 1999 , tspark

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome