Alfa 156 injection warning light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 06-09-08 Thread Starter
Status: -
Join Date: Sep 2008
Location: Macedonia, The Former Yug
County: -
Posts: 4
Alfa 156 injection warning light

hello to evrybody...yesturday my alfa 156 1.8, in the middle of driving..start flashing injection warning light..and the car start to:stop..go ..stop ...go...,i turn the engine off...and after 5 min. i start it again and there was everithing ok...until start again to flash..and the same problem countinue....on the petrol station told me that the petrol is not so clean so they suggest me to put some bottle of "cleaning injection" like 1 bottle on 25 litres of petrol..i did that but the problem is stil the same.......does enyone had this problem with dirty petrol????Can anyone help me????? please...???

(sorry for my bad english)
jekicen156 is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,052
Images: 2
Re: Alfa 156 injection warning light

Hi and welcome to AO. I see you've posted your question in the 156 tech lounge, should get some help in there, good luck with it.
classicgal93 is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: Alfa 156 injection warning light

Best of luck with your problem and welcome to AO
BigFoot is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

156 , alfa , injection , light , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome