New to alfa problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 9 Old 26-08-08 Thread Starter
Status: -
Join Date: Aug 2008
Location: South Africa
County: Gauteng
Posts: 1
Hmmm New to alfa problems

Hi, I am a town planner from South Africa - yes we have development too - who owns 2 alfas - a 2006 alfa 159 2.2 and a 2001 alfa 147 1600. Previously owned an alfa 156 selespeed for 6 years - seem I was the only person in the world who did no have problems - thought it was the best car I ever had. Still sorry I swopped it for the 159. No new selespeeds in South Africa anymore. The 147 is driven by my daughter i Cape Town while I am in Centurion - 1500 km away (1000 miles for some of you) The 147 grounded to an abrupt halt in the middle of the road flashing "sysetms failure" typical isn't it? An I thought the 1600 will be indestructible!
peggysue is offline  
Sponsored Links
Status: Spider's away for winter
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,057
Images: 2
Re: New to alfa problems

Hi Peggysue welcome to AO. Sorry to hear about the 147, have you got a good garage to fix her up?
classicgal93 is offline  
Status: Married
Regional Representative
For East Midlands - AOEM
braddersR's Avatar
Join Date: Jul 2008
Location: United Kingdom
County: Leicestershire
Posts: 42,040
Images: 13
Re: New to alfa problems

hello peggysue...welcome aboard
braddersR is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: New to alfa problems

Hello and Welcome
nigelread is offline  
Mark Alfa
Status: - Update
Posts: n/a
Re: New to alfa problems

Hello and welcome to AO
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: New to alfa problems

Welcome onboard
BigFoot is offline  
Status: -
AO Platinum Member
SPPalfa's Avatar
Join Date: Nov 2007
Location: United Kingdom
County: Newport
Posts: 16,125
Images: 7
Re: New to alfa problems

Hello and welcome to AO - sorry to hear about the 147 - hope its a quick fix

Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
SPPalfa is offline  
Status: -
AO Member
Join Date: Jun 2008
Posts: 79

Member car:

alfa romeo 147

Re: New to alfa problems

Welcome fellow South African.
Kay007 is offline  
Status: It's the silly season
AO Gold Member
Dirk's Avatar
Join Date: Apr 2007
Location: Plett
County: South Africa
Posts: 9,803
Images: 10

Member car:

V6 Sportswagon

Re: New to alfa problems

Hi Peggysue welcome to AO, great to have another SA member
Dirk is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

alfa , problems

« Willie G | Aout me »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome