Alfa Gt 1.9jtd Problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 20-08-08 Thread Starter
Status: -
Join Date: Aug 2008
Posts: 2

Member car:


Not Happy Alfa Gt 1.9jtd Problem

I Have Had My Alfa Gt For 4 Years. As Much As I Love The Car, I Have Had Quite A Few Problems. At The Start Of 2008 I Experienced The Problem With The Management Light Coming On And Loosing Power. The Car Would Still Go, But with No Power. It Would Correct Itself, And Eventually The Light Would Go Out. This Would Happen About Once A Week. Firstly It Was Diagnosed As A Faulty Valve Overboost, Which Was Replaced. The Problem Has Started Again And Alfa Are Saying It Needs A New Turbo. I Have Had The Pipes Smoked For Leaks And I Am Told There Is No Play In The Bearings. Also, An Independant Garage Have Said The Turbo Would Either Work Or Not, Not Intermittent. I Do Not Want To Replace The Turbo, As I Am Not Sure That Is What The Fault Is?
Can Anyone Please help as I am really fed up with it.

jeffh24 is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,052
Images: 2
Re: Alfa Gt 1.9jtd Problem

Hi Jeff welcome to AO. sorry to hear about your problems, hopefully someone will have an answer in the GT tech lounge.
classicgal93 is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

19jtd , alfa , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome