156 dead battery - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 27-07-08 Thread Starter
Status: -
Join Date: Jul 2008
Posts: 3
156 dead battery

Hi Can anyone please help me? I have a 2003 156 2.0 jts and it has sat for 3 weeks unused, so the battery is flat! the central locking wont even open the battery is so flat! I opened it with the key and tryed to start it with a 12v emergency car starter! once conected and the ignition turned on all the lights go on ok but the car just makes a small week attempt to start but wont turn over! When i turn the sterio on it says code! I left the starter connected for 10 mins just to see if that helps but still no joy it just again makes a feeble attempt like its not getting any power! I would be really greatfull for any advise as i dont want to shell out on a expencive call out for something easly fixed if thats the case??
sandy.g36 is offline  
Sponsored Links
Status: Zoe FTW
AO Rosso Alfa Member
baby278278's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Essex
Posts: 46,602
Images: 49
Re: 156 dead battery

Hello and Welcome to the forum

Try posting your question/problem in here for a better response :
Alfa 147, 156 & GT - Alfa Romeo Forum
baby278278 is offline  
Mark Alfa
Status: - Update
Posts: n/a
Re: 156 dead battery

Hello and welcome to AO. Hope you get it sorted
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: 156 dead battery

Hello and welcome
nigelread is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

156 , battery , dead

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome